cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

937
Views
0
Helpful
2
Replies
Masenoe
Beginner

ASA 5516x :dmz to inside connection

Hi!
Am trying to set up my network, the network will have inside, dmz1, dmz2 and outside interface. The most secure interface is dmz1 followed by dmz2 and then the inside interface. dmz1 and inside interface should ping each other. The inside interface is the only interface permitted to access the internet. I know by default a higher security level should ping a lower security level, the problem is after the configuration this is not the case. Am not even able to ping any object in a different zone regardless of the security level, but I am able to access the internet. Below is my configuration kindly help. I am using 5516X (9.8). Thank you.

:
ASA Version 9.8(2)
!
hostname golf
enable password $sha512$5000$1lXki8ZeGrN5kt8X1f8k9g==$cgaW4nsqjgqTWcwsaWcyeA== pbkdf2
names

!
interface GigabitEthernet1/1
nameif outside
security-level 0
ip address 190.156.128.237 255.255.255.248
!
interface GigabitEthernet1/2
nameif inside
security-level 80
ip address 192.168.50.1 255.255.255.0
!
interface GigabitEthernet1/3
nameif DMZ1
security-level 100
ip address 192.168.60.1 255.255.255.0
!
interface GigabitEthernet1/4
nameif DMZ2
security-level 90
ip address 192.168.70.1 255.255.255.0
!
interface GigabitEthernet1/5
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet1/6
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet1/7
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet1/8
shutdown
no nameif
no security-level
no ip address
!
interface Management1/1
management-only
no nameif
no security-level
no ip address
!
ftp mode passive
object network obj_any
subnet 0.0.0.0 0.0.0.0
object network inside_nat
subnet 192.168.50.0 255.255.255.0
object network dmz1
subnet 192.168.60.0 255.255.255.0
object network dmz2
subnet 192.168.70.0 255.255.255.0
access-list inside1 extended permit ip any object dmz1
access-list inside1 extended deny ip any object dmz2
access-list inside1 extended permit ip any any
access-list sfr extended permit ip any any
pager lines 24
logging asdm informational
mtu outside 1500
mtu inside 1500
mtu DMZ1 1500
mtu DMZ2 1500
no failover
no monitor-interface service-module
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
arp rate-limit 16384
!
object network obj_any
nat (any,outside) dynamic interface
object network inside_nat
nat (inside,outside) dynamic interface
access-group inside1 in interface inside
route outside 0.0.0.0 0.0.0.0 197.156.129.233 1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 sctp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
timeout conn-holddown 0:00:15
timeout igp stale-route 0:01:10
user-identity default-domain LOCAL
aaa authentication ssh console LOCAL
aaa authentication login-history
http server enable
http 192.168.1.0 255.255.255.0 inside
http 192.168.50.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
service sw-reset-button
crypto ipsec security-association pmtu-aging infinite
crypto ca trustpool policy
telnet timeout 5
ssh stricthostkeycheck
ssh 192.168.50.0 255.255.255.0 inside
ssh timeout 5
ssh key-exchange group dh-group1-sha1
console timeout 0
dhcpd auto_config outside
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
dynamic-access-policy-record DfltAccessPolicy
username Alfa-1 password $sha512$5000$Tjp0Yo2MhpoDgEfT9c+ikw==$gGq5gHYaHgc3uzg23BGcvg== pbkdf2 privilege 15
!
class-map sfr
match access-list sfr
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum client auto
message-length maximum 512
no tcp-inspection
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
inspect ip-options
inspect icmp
inspect icmp error
class sfr
sfr fail-open
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
Cryptochecksum:600b4f22be9b470abd8a782af49cd12b
: end

 

2 REPLIES 2
nspasov
Cisco Employee

Standard ping is not usually the best way/method to test connectivity. Instead, can you try "packet-tracer" and "ping tcp" and let us know what the results are.

Thank you for rating helpful posts!

Marvin Rhoads
VIP Community Legend

Is this a real network or a class assignment? The config looks suspiciously empty for a real network.